Dodge Challenger Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
its the Alum. bracket that bolts to the engine and the trans U shape..

i need one for 6.4 hemi ti 545rfe
 

·
Registered
Joined
·
223 Posts
Sounds as if a bearing of some sort has worked it's way loose. This may cause the "U" need a joint to have issues like your describing. suggest you take it to dealer immediately and have him look at the muffler bearing first.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #4
I wrote that post and then could not figure out how to post a picture...why are other forums so easy to post a pic....?
 

·
Registered
2014 SXT
Joined
·
50 Posts
Sounds as if a bearing of some sort has worked it's way loose. This may cause the "U" need a joint to have issues like your describing. suggest you take it to dealer immediately and have him look at the muffler bearing first.
I had that problem and the dealer said bearings were on back order from China as soon as they were shipped from Mexico.:grin2:
 

·
Registered
Joined
·
675 Posts
Your talking about the aluminium brace that bolts to the bottom of engine with 4 bolts and connects the bottom of the bellhousing to the engine. Not sure of what its called. Have taken many off and on to do engine/trans swaps. Allows you to get to the torque converter bolts.
 

·
Registered
Joined
·
776 Posts
Your talking about the aluminium brace that bolts to the bottom of engine with 4 bolts and connects the bottom of the bellhousing to the engine. Not sure of what its called. Have taken many off and on to do engine/trans swaps. Allows you to get to the torque converter bolts.
5 year old thread bud.


Sent from my iPhone using Tapatalk
 
1 - 10 of 10 Posts
Top