Dodge Challenger Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey folks,
I just recently purchased a pre-owned 2010 Challenger and I love the car!! The winsheld wiper fluid at highway speeds has a steady leak onto my hood without me ever using it at all.....
Is anyone else having this issue?
My tech says he doesnt know if its normal....LMAO.

Let me know

Thanks
 

·
Registered
Joined
·
3,532 Posts
SLOW DOWN!! youre driving to fast and creating a vacuum that is sucking out the fluid. Keep it under 100 mph and youll be ok.



jk
 

·
Registered
Joined
·
2,544 Posts
Don't use the washers. With them located on the hood that stuff is going to be the norm.
 

·
Registered
Joined
·
554 Posts
Hey folks,
I just recently purchased a pre-owned 2010 Challenger and I love the car!! The winsheld wiper fluid at highway speeds has a steady leak onto my hood without me ever using it at all.....
Is anyone else having this issue?
My tech says he doesnt know if its normal....LMAO.

Let me know

Thanks
Same here. Have 10.000 miles and I noticed this leak a week ago. Not normal.
 

·
Registered
Joined
·
497 Posts
I hate HATE those things on the hood. why even put them there? That is my single biggest complaint with this car (one of few). They should have put them on the wipers. in the off chance I have to use my wipers(only drive on nice days, but bugs can be a problem) I have to look at the overspray marks until I wash her again. REDICULOUS. Sounds like you need a new pump though :(
 

·
Registered
Joined
·
554 Posts
Checked the washer fluid and it was low. Going highway speeds tomorrow so I'll know if low fluid was the problem.
 

·
Registered
Joined
·
637 Posts
It happen to me too.
 
1 - 8 of 8 Posts
Top